Skip to content

FirstAlert OneLink Wired (non safe sound) Push Notifications dont work

FirstAlert OneLink Wired (non safe sound) Push Notifications dont work

First off, what this post describes a year ago is also happening today in 2020: https://www.homekit.blog.com/r/HomeKit/comments/bmcuo3/the_automation_you_hope_never_runs/?utm_source=share&utm_medium=ios_app&utm_name=iossmf

1. I’ve created an account, I know one is required.

2. I’ve set up the device in the OneLink Home app

3. Paired to homekit after setup in the app completed

4. Suck on my vape, blow it at the device. Alarm goes off.

5. Look at my phone, no notification. Hmmf

6. Staring at my phone, the smoke dissipates, alarm still loud, no notification.

7. Smoke clear. Alarm stops sounding. No notification.

8. Look at the app, history log. Only record is from the manual push button test I did. I’ve triggered the alarm with various means about 5 times now. No record in the app. The app doesn’t know it happened. Issue 1.

9. Check homekit. “Smoke detected: No” never changes homekit is also unaware anything happened. Issue 2.

10. We know the device is connected to WiFi because when I change arbitrary setting such as LED brightness it waits, syncs, and responds appropriately. Restarting the device works too.

11. We know the device is connected to homekit because homekit is showing no errors and “identify device” works.

12. I’ve tried both setting up the device through the app as well as factory reset and then set up directly through homekit using the code, and then setting up with the app. I understand that an account is required for push notifications (or so First Alert claims) to work, but since I have an account and they’re still not working this is issue 3; the primary issue.

push notifications, easily the most important aspect of this “smart” smoke alarm, are broken. JFC.