Skip to content

HKV Logitech Circle 2 Camera no answer

I upgraded the Logitech Circle 2 with video cables to Homekit Secure a few months ago and it worked great until recently using the latest firmware. Last week I had to unplug the camera, and when I plugged it back in, it didn’t respond in the home app.

I tried to turn on the device, reset the camera (pressing the button until the LED glowed green-purple) and remove the camera from the house, but that didn’t solve the problem. I contacted Logitech support. They guided me through various troubleshooting steps (disconnecting the camera, restarting the router and hub at home, removing the lens from the stand for 15-20 minutes, reassembling the camera, restoring power, and pressing the reset button until it glowed purple -red), but still nothing. I’ve read posts suggesting that I may have to reset the camera many times because it works – I’ve probably tired it 50 times, but nothing happens after I release the reset button. After I release the button, the LED does nothing and the camera cannot be found to add it back to the house.

A Logi support expert said many people had similar problems due to a possible hardware defect. After their troubleshooting suggestions failed to fix the problem, their solution was to give me a 30% discount on a new room because the room has no warranty. This is not good for me. If it’s a known flaw, it looks like it should take responsibility, but I doubt it will.

Does anyone have any ideas?