HomeKit is doing the 'No Response' thing and I'm out of things to try

Cupertino, October 4, 2021

EDIT: thanks to a tip from /u/Firehed I managed to fix it by resetting my Apple TV’s

I've had HomeKit woes in the past but they were over since I got rid of my HomePods. But since last week I have a growing problem with 'No Response' errors. It started after updating my wife's iPhone 12 mini to iOS 15 - home.app would eat through battery like crazy, so I deleted the Home.app, disabled Home in her iCloud settings. Battery problem fixed, but after installing and re-anbling Home in iCloud, the [Home.app](https://Home.app) would remain empty. She could still control HomeKit on her iPad though. Back then no problems on any of my devices; I'm the main iCloud user and Owner of the Home.

Then I got an iPhone 13 Pro and installed it last Monday. It worked fine for a few days but then started giving 'No Response' for all HomeKit devices except Apple TVs and switches. When I tap a Scene it shows a 'Failed' error. My other devices still worked including my previous iPhone 11 Pro Max. But we're a few days later and now I can't use HomeKit on any iOS, iPadOS or MacOS. Both the built in app as well as Home+, Eve have the same problem that started on my new iPhone.

Automations (e.g. motion sensors, timers) and wall switches still work though, and the Apple TV (also on tvOS 15) lets me use the remote to trigger favourite scenes and watch cameras. I have a Unifi network with UDM Pro as router and Wifi6 Lite & LR access points and a single, shared SSID for both Apple and IOT devices that operates on both 2.4 and 5Ghz.

What I've tried so far, all without success:

* Unplugged all 3 Apple TV (4K 2021) and plugged them back in (the home app did give home hub responding/not responding notifications as expected)
* Disable IPv6
* Switched various Unifi settings on and off: IGMP snooping, Multicast Enhancement, Optimise IoT Wifi Connectivity, followed by rebooting the UDM Pro and Apple Devices
* Shut down HomeBridge
* Update UDM Pro to the latest non-beta firmware
* Verify that Discovery could see the devices (_hap._tcp for most and _hap._udp for Thread devices)[
* Disable wifi on MacOS to ensure it connects over ethernet or 5G

So it's not iOS 15 (as MacOS is not updated). It's not iPhone 13 Pro. It's not Wifi (as it's also happening when on ethernet). I've run out of things to try other then fully wiping my home and/or Unifi. Any thoughts?

Best selling & Top trending HomeKit product in our shop at this moment

HomeKit.Blog is in no way affiliated with or endorsed by Apple Inc. or Apple related subsidiaries.

All images, videos and logos are the copyright of the respective rights holders, and this website does not claim ownership or copyright of the aforementioned.

All information about products mentioned on this site has been collected in good faith. However, the information relating to them, may not be 100% accurate, as we only rely on the information we are able to gather from the companies themselves or the resellers who stock these products, and therefore cannot be held responsible for any inaccuracies arising from the aforementioned sources, or any subsequent changes that are made that we have not been made aware of.

HomeKit.Blog Is A Participant In The Amazon Services LLC Associates Program, An Affiliate Advertising Program Designed To Provide A Means For Sites To Earn Advertising Fees By Advertising And Linking To Amazon Store (Amazon.com, Or Endless.com, MYHABIT.com, SmallParts.com, Or AmazonWireless.com).

The opinions expressed on this website by our contributors do not necessarily represent the views of the website owners. 

Copyright © 2022 HomeKit Blog
. All rights reserved
United States