Skip to content

HomeKit – Troubleshooting success (for once)

HomeKit – Troubleshooting success (for once)

Wanted to share a recent trouble-shooting session I had involving HomeKit, Google Nest WiFi, xfinity, iPhones, meross smart plugs, and an ecobee thermostat.

Symptom 1: One of two ecobees and alternating meross switches consistently showing up as “unresponsive” in HomeKit. Not a major concern but annoying during Halloween and having routines/automation disrupted.
Symptom 2: Intermittent “incorrect password” error on iPhones. Again, super annoying.
Symptom 3: Aforementioned ecobees and meross plugs intermittently disconnecting from WiFi completely. Not coinciding with HomeKit unresponsiveness, though.

Tried all the known tricks (soft/hard resets, network mapping, ipv4/6 restricting, etc) on everything (devices, hubs, apps) for over a week. Always hoping that things would “settle” and become stable. More than significant WiFi coverage at all locations (100-400 mb/s).

What ended up finally working.

1) Changed Nest WiFi’s DNS setting from “google” to “ISP”
2) Relocated the Nest WiFi access point far enough away from the ecobee that the ecobee would connect to the Nest router (along with the other ecobee that wasn’t giving me issues)

I’m still not completely sure why this worked (obviously I did those things for a reason), but hoping that I may save someone time in the future. I know Reddit can be a rabbit hole at times when troubleshooting, and I’ve done my fair share of following some crazy paths (including this past week of troubleshooting). But definitely a fan of crowd-sourced trouble shooting, especially when dealing with all these different OEMs.