Leviton switch help!

Cupertino, July 28, 2023

I have a 1st generation Leviton switch (DH15S-1BZ) that has worked fine for a couple of years. Recently it was unresponsive in HomeKit. I was unable to get it working, so deleted it from HomeKit. Now I am unable to re-add it. I get a message "Unable to Add Accessory The setup code is incorrect". It is 100% the correct code. I have tried to add bother via HomeKit, the DecoraSmart app, and the My Leviton app with the same results. It starts the process and the switch connects to my WiFi but seems to stall at that point. Any suggestions? Thanks

Best selling & Top trending HomeKit product in our shop at this moment

HomeKit.Blog is in no way affiliated with or endorsed by Apple Inc. or Apple related subsidiaries.

All images, videos and logos are the copyright of the respective rights holders, and this website does not claim ownership or copyright of the aforementioned.

All information about products mentioned on this site has been collected in good faith. However, the information relating to them, may not be 100% accurate, as we only rely on the information we are able to gather from the companies themselves or the resellers who stock these products, and therefore cannot be held responsible for any inaccuracies arising from the aforementioned sources, or any subsequent changes that are made that we have not been made aware of.

HomeKit.Blog Is A Participant In The Amazon Services LLC Associates Program, An Affiliate Advertising Program Designed To Provide A Means For Sites To Earn Advertising Fees By Advertising And Linking To Amazon Store (Amazon.com, Or Endless.com, MYHABIT.com, SmallParts.com, Or AmazonWireless.com).

The opinions expressed on this website by our contributors do not necessarily represent the views of the website owners. 

Copyright © 2022 HomeKit Blog
. All rights reserved
United States