Skip to content

Location-based automation doesn’t work – am I missing something?

Location-based automation doesn’t work – am I missing something?

Hi, I’m trying to set up location-based automation, for example to start my robovac (connected via Homebridge) at 1pm only when I’m not home. However, automation never works. I searched online and in subhomekit.blog, but I didn’t find anything else that could help. I checked the following. Am I missing something or does anyone have any suggestions? – I’ve confirmed that my iPhone is used for location in iCloud settings, – I’ve confirmed that HomeKit and the Home app on the phone have permission to use Location Services, including Precise Location, – I’ve turned off Home Location Services on iPad my (which usually stays at home) in case of interference with the device, – I tried to get the iPad out of the house anyway to be safe, – I checked if the address is correct using the Eve Home app and my contact card , – I’ve confirmed that it’s not a problem with Homebridge by setting up a compatible native device (Rio Arc Heater) that only starts at a set time when I’m home – it started even if I was at work. – We were able to set up automations based on arrival at another location (office), so it seems to be a problem only with the house. Is there any other setting I overlooked or any suggestions for trying to fix it? Good luck in advance!