Meross smart plug firmware version 7.2.9 fixed connectivity issues for me

Cupertino, October 5, 2021

I saw the 7.2.9 update last week for my Meross smart plugs, which were at 7.2.3 previously. I have 6 of these plugs, and 2 were doing the infamous Homekit lost connection thing intermittently (1 especially). Now since updating to 7.2.9 I have not seen a single instance of lost connections since updating, looks to be an outright fix. Happy to see this! Per the 7.2.9 release note: "greatly optimized connection stability issues"

https://preview.redd.it/fg73vg83ubo71.png?width=978&format=png&auto=webp&s=4d125c50faeafb2c535ea55894af7f0d4f60f4cf

Best selling & Top trending HomeKit product in our shop at this moment

HomeKit.Blog is in no way affiliated with or endorsed by Apple Inc. or Apple related subsidiaries.

All images, videos and logos are the copyright of the respective rights holders, and this website does not claim ownership or copyright of the aforementioned.

All information about products mentioned on this site has been collected in good faith. However, the information relating to them, may not be 100% accurate, as we only rely on the information we are able to gather from the companies themselves or the resellers who stock these products, and therefore cannot be held responsible for any inaccuracies arising from the aforementioned sources, or any subsequent changes that are made that we have not been made aware of.

HomeKit.Blog Is A Participant In The Amazon Services LLC Associates Program, An Affiliate Advertising Program Designed To Provide A Means For Sites To Earn Advertising Fees By Advertising And Linking To Amazon Store (Amazon.com, Or Endless.com, MYHABIT.com, SmallParts.com, Or AmazonWireless.com).

The opinions expressed on this website by our contributors do not necessarily represent the views of the website owners. 

Copyright © 2022 . All rights reserved
United States