Problem loading accessories

Cupertino, January 31, 2021

I know this thread has often appeared in the past, but now I've tried everything. When I launch the Home app it stays on the "Upload props and scenes" screen indefinitely. So far I've tried A different device - my iPad looks good at home, so it's not the only iCloud account A different iCloud account - works on both devices, so it's not the device So it seems to be a combination of my iCloud and iPhone account 12. I pull my hair out after trying everything. If you have anything you can think of, please let me know and I will be very grateful

Best selling & Top trending HomeKit product in our shop at this moment

HomeKit.Blog is in no way affiliated with or endorsed by Apple Inc. or Apple related subsidiaries.

All images, videos and logos are the copyright of the respective rights holders, and this website does not claim ownership or copyright of the aforementioned.

All information about products mentioned on this site has been collected in good faith. However, the information relating to them, may not be 100% accurate, as we only rely on the information we are able to gather from the companies themselves or the resellers who stock these products, and therefore cannot be held responsible for any inaccuracies arising from the aforementioned sources, or any subsequent changes that are made that we have not been made aware of.

HomeKit.Blog Is A Participant In The Amazon Services LLC Associates Program, An Affiliate Advertising Program Designed To Provide A Means For Sites To Earn Advertising Fees By Advertising And Linking To Amazon Store (, Or,,, Or

The opinions expressed on this website by our contributors do not necessarily represent the views of the website owners. 

Copyright © 2022 . All rights reserved
United States