Skip to content

Siri and Automations no longer work with Homekit (Meross smart sockets) after they worked well initially

Siri and Automations no longer work with Homekit (Meross smart sockets) after they worked well initially

Hi, folks, I hope to find someone else who has this common experience. I bought a pack of four Meross smart plugs and, after setting them up with a bit of frustration, they worked fine. We built scenes, an automation to turn on the bright lights at 17:00 and they were controllable through Siri. This lasted a day or two and then both Siri commands and automations stopped working. I was still able to control the outlets manually via the Home application, even though siri and automation stopped working. But this is not ideal and not how it should work. When I tell Siri to turn on the lights in the living room, he replies, “I’m sorry, I couldn’t find something like this in your house at this time,” and the automation just doesn’t work. Again, a day or two after I installed these devices, both things worked fine and inexplicably stopped working. Here’s what I’ve been doing ever since. I deleted the devices, used the Meross app to update the socket firmware to the latest ones, then fixed them with homekit (this was a huge pain in the ass, which is another topic entirely), but I’ll be right back where did we start. Manual control in the house works well, but siri and automation timers simply do not work. I contacted Apple support, but I’m sure you can imagine how it went. This is clearly a kind of problem with iOS software and I wonder if any of you here have experienced something similar, with Meross devices or otherwise, and maybe found a solution. I feel the desire to add more and more smart devices to my house and I would like to use Homekit, but if this is a model, it is not even close to being ready for prime time. Thank you for taking the time to read this. EDIT: Figuratively, I’d better add some information. I’m using an iPhone 12 Pro Max with iOS 14.4, and the Meross plugs have been updated to the latest firmware. I don’t have a homehub right now.