Skip to content

Siri and Hunter Fan Control: Inconsistent between devices

Siri and Hunter Fan Control: Inconsistent between devices

Hello everyone! This is kind of a weird problem and I couldn’t find a mention when I did a search, so I thought I’d post about it for thought. (There’s also a little question about the MacOS Home app at the bottom that doesn’t seem to justify its own thread.) I’m a Hunter Romulus fan. Overall, it works great. After reading the experiences of others, I must say that it can work better than wonderful and I did not realize how lucky I was. I can easily control the light and speed / direction of the fan in the Home applications on my devices, and the fan responds quickly. The problem is voice control, especially for the fan. I have two HomePods in a pair and two HomePod minis, as well as a series of iPhones and iPads for the family. One HomePod mini seems to be able to reliably adjust the fan speed; it doesn’t seem to adjust at all (although there is a confirmation feedback from Siri). My iPhone and iPad can adjust it from apps or even widgets, but I usually can’t if I issue voice commands through Siri (although I’m usually lucky, I tested it while typing this posting and of course now works). I specify which room fan to use when issuing the voice command, although it should be noted that this is the only smart fan I have at the moment and that there are no other fan-like devices listed in the HomeKit. The fan and light are grouped as a single tile in the Home app, though I don’t know what should make the difference. I’m mostly curious if anyone else has seen this before and if there is a suggested solution for it, other than avoiding voice commands or always checking for tracking. For the sake of completion, I would notice that with lighting, there is a strangeness in the fact that turning on the light and then adjusting the brightness requires two controls. For example, if the light is off and they say “set the lights to 50%” (or only “50”), the lights will turn on and remain at the last brightness level before going out. Once turned on, they respond to brightness commands. I have a bunch of smart bulbs from VOCOlinc and you can turn them on at the specified brightness with a single command. Lighting control seems to work reliably, though. Finally and somewhat unrelated, after one of the macOS updates (I don’t remember which one) I started to notice that when you open a tile for the device control (if two or more controls are in the tile; for simple devices, do right click and “display commands” gives you the same feature) the app will open it as expected and then it will automatically scroll down slightly to open the settings, as if trying to tell you that you could scroll down for more options. An excellent solution to Apple’s design decision to hide an idle scroll bar for those of us who use trackpads and who completely lack the fact that there are more windows, but also a nuisance. I can’t find a way to disable this feature … has anyone experienced this and do you know how to turn it off?