Skip to content

Temporarily stopping geolocation has triggered automation to run

Temporarily stopping geolocation has triggered automation to run

Hello – I have a random situation where I’m sure there must be an easy solution, but I can’t think about it. I recently traded in [alarm.com](https://alarm.com) security system for a Lyric with native HomeKit functionality. In the last few weeks, through trial and error, my automations work perfectly where all my lights go out and my alarm system comes on when I leave and the garage door opens and my security system disarms on arrival. All this is done by geolocation and fictitious switches, so as not to receive confirmation messages. I’m currently redoing my bathrooms and I have a contractor on site. Sometimes I have to leave home and I don’t want the alarm system to go off while the contractor is here. What is the best way to prevent running geolocation-triggered automation? Today I turned off my phone and it worked, but it took about 30 minutes until everything came back online when I restarted the phone. I thought putting the phone in airplane mode while leaving the area might work, but I haven’t tested it yet. What would you recommend to do in this situation? Thanks!