Troubleshooting the Aqara M2 hub configuration

Cupertino, January 30, 2021

Hi, I just got the Aqara M2 hub. You connected it to the power supply and router using an Ethernet cable. I tried to pair it with Aqara and HomeKit, but I keep getting this: Once connected (or reset), the light turns static red for a few minutes. Then static orange. Then green. I looked for what green means. But the description of the status light says nothing about green. I tried to reset it, but I get the same result. ☹️ Anyone know what this could be? EDIT: I managed to bring it to the intermittent yellow state. But it still can't connect to the HomeKit / Aqara app

Best selling & Top trending HomeKit product in our shop at this moment

HomeKit.Blog is in no way affiliated with or endorsed by Apple Inc. or Apple related subsidiaries.

All images, videos and logos are the copyright of the respective rights holders, and this website does not claim ownership or copyright of the aforementioned.

All information about products mentioned on this site has been collected in good faith. However, the information relating to them, may not be 100% accurate, as we only rely on the information we are able to gather from the companies themselves or the resellers who stock these products, and therefore cannot be held responsible for any inaccuracies arising from the aforementioned sources, or any subsequent changes that are made that we have not been made aware of.

HomeKit.Blog Is A Participant In The Amazon Services LLC Associates Program, An Affiliate Advertising Program Designed To Provide A Means For Sites To Earn Advertising Fees By Advertising And Linking To Amazon Store (, Or,,, Or

The opinions expressed on this website by our contributors do not necessarily represent the views of the website owners. 

Copyright © 2022 HomeKit Blog
. All rights reserved
United States