Skip to content

You cannot add Logitech Pop to the HomeKit

You cannot add Logitech Pop to the HomeKit

So my ISP changed my router and therefore I had to reconnect most of my HomeKit stuff. Everything went well except Pop.

I have no idea how many power cycles I have sent the bridge so far and no idea how many times I reset both the bridge and the button to the factory default settings. Nothing works. Using the * fantastic * Logitech Pop app, I can add the button there, but every time I try and click “Add this button to HomeKit”, it first tells me that this button is already in the Home app (which is not – triple -a checked all the cameras), so I say “Add anyway”, it says “Ok done”, but I didn’t add it in the Home app. Tried it 10 times. Without success. So uninstall this app again and try using the HomeKit code on the bridge. Most of the time it doesn’t work and it says “Couldn’t connect to accessory”, but twice, it worked: It also added the button (no idea where it got the button from) to the Home app and I he thought it worked for a second. So, set up a few scenes and things, then went to try it: Nothing. Double press: Nothing. Long press: Nothing.

Give it all up, reset everything to the factory default settings. Back to the Pop Logitech app. The bridge is still there, when I click on the plus on the top right to connect a new button, it sends the bridge into pairing mode (indicated by LED). So you pressed the button: And even now the Logitech Pop application can’t find the f * ing button.

The button worked well before. What else can I do now? Or just throw it away?